PDA

View Full Version : EMC LOYALIST outfit, its a glitchfest.



lllWARCHILDlll
07-02-2013, 02:31 PM
So, had bits from last month, bought the emc loyalist outfit. Went to an arkfall.
Arkfall chrystal was not there, players were there... all shooting at things that wouldn't load up on the screen in the game.

Opened character menu, switched to EREP outfit.
Arkfall chrystal appeared, creatures showed up, all the OTHER players disappeared from the screen in the game... still had metal barriers.

Switched back to the emc loyalist outfit.

Arkfall chrystal disappeared, all the scrap metal barriers disappeared, players appeared in default outfits (as usual), creatures were all invisible causing damage and throwing everyone around.

Put back on the EREP outfit....

Chrystal was back, all players disappeared, metal barriers were back, creatures were visible.

Soooooo......

Anybody feel like verifying this if you have the emc loyalist outfit? Cause "IF" this is really whats going on with players issues.... it would really suck really hard if what we can and cant see is based on of all things, the OUTFITS we wear in the game. Seriously. WTF Trion.

OH YEA and I almost forgot. Wearing the outfit repeatedly appears to kick you out of the runner while driving it.

Councilworker
07-03-2013, 02:19 AM
Yes, the EMC Loyalist Outfit is glitched and thanks for confirming that I am not the only one to have a problem with it.

I had, I could see the roadside emergencies trucks / eggs whatever but no bad guys till I changed outfits, same at fixed missions such as the farms and also Arkfalls. Turned up to a hellbug final, everyone firing away no enemies in sight or the large hive / creature even, only the Hellion only baddie visible.

Have reported the bug via in game feed-back, I would suggest you do the same (if you haven't). Did some testing if you have the helmet that works fine, it only the outfit that's glitched.