PDA

View Full Version : The game is very laggy for me, even on low settings.



Shaggy_Xx
07-19-2013, 08:03 AM
It's not like I have a bad computer, I have a better computer then my friend who I'm playing with but he doesn't have any of this lag. The game will randomly like drop a ton of frame rate and just freeze and it happens so much it's annoying as hell.
I googled trying to find a fix but didn't find anything.

TLDR Game laggy help pls

Sanguinesun
07-19-2013, 08:15 AM
It's not like I have a bad computer, I have a better computer then my friend who I'm playing with but he doesn't have any of this lag. The game will randomly like drop a ton of frame rate and just freeze and it happens so much it's annoying as hell.
I googled trying to find a fix but didn't find anything.

TLDR Game laggy help pls

Since the patch last week or so its been like this for folks unfortunately.

Ido
07-19-2013, 08:16 AM
What gpu do you and your friend use? On my Laptop with an Ati card everything is fine but on my desktop with nvidea the game stutters likes theres no tomorrow it is an old 295GTX though

Shaggy_Xx
07-19-2013, 08:54 AM
Since the patch last week or so its been like this for folks unfortunately.

man this sucks. Hope it gets fixxed soon.

Kymer
07-19-2013, 08:59 AM
It was like that a few days ago when i was last on. Doesn't always seen to follow a patch, and sometimes rebooting my comp fixes it but not always.

Shaggy_Xx
07-19-2013, 09:14 AM
It was like that a few days ago when i was last on. Doesn't always seen to follow a patch, and sometimes rebooting my comp fixes it but not always.

Ya i tried restarting and even reinstalling but it didn't fix it. Oh well hope a new patch fixes it.

maxila
07-19-2013, 10:16 AM
TLDR Game laggy help pls

Since the patch I've noticed occassional server lag which you can identify by things like a weapon that gives a primary and secondary explosion, the second one is delayed well past it usual detonation time, npc mobs seem to warp move from time to time, in arkfalls and emergencies unusual delays in addittional spwans of mobs, etc.

Low frame rates and a general jerky movement tends to be your own PC and/or internet connection. On low settings the game is not a huge video hog if you are using the minimum recommended hardware. The most probable culprit is CPU, most people don't realize in a MMO CPU power is more often the cause of slowdowns than video, internet connection speed is second, and video is third, but they are all factors to look at carefully.

Sanguinesun
07-19-2013, 10:49 AM
It was like that a few days ago when i was last on. Doesn't always seen to follow a patch, and sometimes rebooting my comp fixes it but not always.

Not following -a- patch. Following last weeks patch. Its been discussed before and it also resembles an issue that used to be bad during alpha which leads me personally to believe its something on their side they changed inadvertently or by design(if no choice for some reason in favor of some other needed feature).

Shaggy_Xx
07-19-2013, 12:25 PM
Low frame rates and a general jerky movement

thats what I get. My computer is definitely not bad so that's not the problem, my internet is fine while doing it, it's been identified as the last patch by like 5 people now.

Shaggy_Xx
07-19-2013, 12:33 PM
What gpu do you and your friend use? On my Laptop with an Ati card everything is fine but on my desktop with nvidea the game stutters likes theres no tomorrow it is an old 295GTX though

My friend has some ****ty like 2-300 lappy and I have a desktop I built myself, nvida GTX 480 and amd phenom 2 x2 545 3.00 ghz