PDA

View Full Version : Premature Completion



FordLover
08-02-2013, 01:15 PM
While playing the Co-op Map Soleptor Excavation, the "Completion" screen came up and said I'd completed the map. After having only gotten to the second bend in the map? I was ejected from the map, and it said the group had left the instance. I get booted and then I'm standing aways from Diablo Station next to the ammo crate. I tried rejoining them, however I couldn't so I had to leave.

I tried again, and the same thing happened: the "Completion" screen comes up, I'm booted, message says the group left, and I'm standing outside of Diablo Station next to the ammo crate.

Just to make sure it wasn't just that one map, I tried Explosions 101 and Liberate the Lost. Both times the same thing happened. Hopefully someone or a group of someones is looking into this because I've about had it. I'm tired of this happening and something needs to be done ASAP. I really like this game, It's a way my brothers and I get to "see" each other since we live so far apart and to have this kind of thing happening on a regular, and very annoying, basis is unacceptable. I understand things happen and PS3's internet speed isn't the greatest, however that's no excuse for things like this to be occurring.

Thank you for your time to read this.