PDA

View Full Version : Got a bit of a problem



KashraFall
04-01-2013, 03:14 PM
I bought the game via Origin this was before the game was able to be bought on steam. I registered the account, it even shows codes applied and when I try to log in, it says this account isn't registered to play on defiance? Any suggestions?

DarkKnyt29
04-01-2013, 03:31 PM
May have to do Customer Support on that one, friend

KashraFall
04-01-2013, 03:48 PM
Tried to get help via their support, but it seems their live chat service is down or something. Soo, guess I am screwed till I can get helped.

Defy
04-01-2013, 03:49 PM
was this game available through origin? I didnt know that

KashraFall
04-01-2013, 03:51 PM
Yup, it was how I found out about it. I infact had to go one step further when I ordered it through origin and contact them as well, because when I bought the game intially,it didn't appear on the "My Games" tab. So I had to wait aprox, two hours to get them to respond and they fixed it in a matter of moments. I used the codes provided and activated my account which entered me into the beta drawing but I decided not to play the beta as to not ruin any experience I would have from a "Wow" factor point of view.

Defy
04-01-2013, 03:54 PM
well one workaround I read about that worked for someone with the same error message is to reset your Trion password

worth a shot

KashraFall
04-01-2013, 03:56 PM
Thanks for the help defy, that actually worked. A bit of a bother but at least it fixed my issues. See you in world when I can.