PDA

View Full Version : TRION HELP Purple CRIT barrel doesn't work (attached)



Left2Smoke420
11-05-2013, 12:59 PM
I equipped a critical barrel tier 4 1.20 to my syphon wolfhound where the crit DMG before doing so was 5.8. I did the math and it should had gave me at least 6.9 crit DMG but instead it only had 6.6 crit DMG. That's the amount I would of got if I attached a regular 1.15 blue tier 3 barrel. Has anybody got the same problem with a tier 4 mod?. Im not feeling that at all and please correct me if I'm wrong. Thanks for reading

Kaiselius
11-05-2013, 01:11 PM
It's probably not broken. You probably just hit the stat cap for crits on the wolfhound.

Critical Errors
11-05-2013, 01:15 PM
I also thought I had this problem. Set up a post about it and the community helped explain some things. You were most likely adding the multipliers the wrong way.
Here's the link to my post:http://forums.defiance.com/showthread.php?138842-Do-all-guns-in-game-have-a-Stats-cap

Read through the comments, and maybe it'll help you get a better grasp on stats.

Left2Smoke420
11-05-2013, 01:27 PM
I also thought I had this problem. Set up a post about it and the community helped explain some things. You were most likely adding the multipliers the wrong way.
Here's the link to my post:http://forums.defiance.com/showthread.php?138842-Do-all-guns-in-game-have-a-Stats-cap

Read through the comments, and maybe it'll help you get a better grasp on stats.

I had a total 1.60 of added crit to my pistol a 60% of 4.0 would be near 6.6 thank you for helping.

Critical Errors
11-05-2013, 01:31 PM
I had a total 1.60 of added crit to my pistol a 60% of 4.0 would be near 6.6 thank you for helping.

List the stats of the weapon, and I can walk you through it.

edit: You forgot to add the skills bonus of x1.05 into that. That would bring it up to 6.6

Zugo
11-05-2013, 01:33 PM
I had a total 1.60 of added crit to my pistol a 60% of 4.0 would be near 6.6 thank you for helping.

While in the salvage matrix, the screen that is displayed after selecting a mod, and prior to clicking "Start Action" is not functioning correctly.

Left2Smoke420
11-05-2013, 02:00 PM
While in the salvage matrix, the screen that is displayed after selecting a mod, and prior to clicking "Start Action" is not functioning correctly.

Damn right about that it had tricked me few times already, damn salvage matrix.

Left2Smoke420
11-05-2013, 02:03 PM
List the stats of the weapon, and I can walk you through it.

edit: You forgot to add the skills bonus of x1.05 into that. That would bring it up to 6.6


I did added it up. I do get why is 6.6 because of your previous post. I did read that thread gave me some good information, thanks again.