PDA

View Full Version : Open mics by default = NOISE SPAM in all pvp...



hugdealer
04-02-2013, 09:20 AM
how the heck do i mute ALL VOICE CHAT?

whenever i join a pvp event, it's immediately filled with
distorted echoing garble from multiple people.
it's either play the game on mute, or deal with it.

i only see a way to mute individuals.
that might help, but people on mics don't have any indication
that they are speaking.

PLEASE let me know if there is a way to mute all voice chat.
i turned my own voice off in options, but there seems to
be no volume slider for incoming mics.

Bendiix
04-02-2013, 09:26 AM
You need to press Ctrl then select the player with noice and click mute, thats the only way to do it i think... sad but u need to do it 1 by 1

Monkerlotus
04-02-2013, 09:29 AM
oooooooh ctrl is what does that? i was scrambling so hard to figure out how to mute effectively lol... i used the setup menu to que into pvp and stuff XD

apocalikik
04-02-2013, 09:34 AM
I go into settings, then audio, then click voice, off. If its already off turn it on then back off. The problem is once you log out or exit game and come back it starts all over again.

hugdealer
04-02-2013, 09:39 AM
I go into settings, then audio, then click voice, off. If its already off turn it on then back off. The problem is once you log out or exit game and come back it starts all over again.

hmm, thanks i'll mess with that.

i really hope trion fixes this. not going to hold my breath :\

Azslast
04-02-2013, 09:40 AM
Nothing like a good old table top mic feed loop to deafen your ears.

KodiakX
04-02-2013, 09:45 AM
Yea the only way to keep sane in any kind of group setting is to turn off the voice in game and toggle on/off if it's already off otherwise you'll go mad listening to the random mumblings of an internet fat guy.

Komakala
04-02-2013, 09:46 AM
If you go into Settings, Audio there is a Voice option, flip it off and it disables all voice chat. I run with it off unless I'm doing a clan event.

Bizar
04-02-2013, 09:49 AM
Does mute yourself too? I tend to sit on mumble with guildmates from Rift who aren't playing Defiance and chat to them. Would be nice to know that by turning voice off I'm not spamming other people by accident while I talk on mumble :p

EllmansWorld
04-02-2013, 09:53 AM
Is this a issue on Console or pc?

KodiakX
04-02-2013, 09:56 AM
If you go into Settings, Audio there is a Voice option, flip it off and it disables all voice chat. I run with it off unless I'm doing a clan event.

Comes back on if you exit the game. Gotta turn it back on and apply then back off and apply to fix it being off again.


Does mute yourself too? I tend to sit on mumble with guildmates from Rift who aren't playing Defiance and chat to them. Would be nice to know that by turning voice off I'm not spamming other people by accident while I talk on mumble :p

Yes

Komakala
04-02-2013, 09:56 AM
As far as I know it mutes you too. I haven't had any complaints from my clan yet about my mic being open and spamming useless noise.

KodiakX
04-02-2013, 10:20 AM
As far as I know it mutes you too. I haven't had any complaints from my clan yet about my mic being open and spamming useless noise.

Because you know about it. There are a lot of other people in things like Shadow War PvP or Co-Op dungeons where people have some mic that they don't even realize they have built into their laptop or all-in-one desktop PC that are on. In Dungeons you can mute the players individually, but this also blocks their chat. In Shadow War PvP, the only option is to toggle it off entirely or listen to the ramblings of an internet fat guy or the disco superstar blarring out favorites from the 70s and other various stereo types.

hugdealer
04-02-2013, 08:51 PM
i'm having the issue on pc, hence posting in the pc section.

toggling Voice on and off does turn it off, you have to do it each time you load up the game.

Kroktar
04-05-2013, 10:30 PM
this is so ****ing annoying... this was designed to work like xbox live spam mics?...****ing consoles >:(