View Full Version : Tutorial: Ego powers

04-03-2013, 05:20 AM
During the tutorial mission which requires you to use your ego powers to see which one you like best I guess? During the stealth part, I am unable to proceed. My power will not work, in fact it doesn't even come up next to the grenade picture where it is supposed to be. I would try abandoning the mission but I am unable to? Also, I would like to keep my character as after I saw this glitch I thought making another character would be okay and I could just play on the new one, but I noticed I do not get any of my pre-order bonuses or my Ark-fall hunter rewards I have on my first one. Any help is really appreciated! Thanks!

04-03-2013, 05:25 AM
You shouldn't have been able to claim your Ark Hunter or Pre-order bonuses before getting to that point. That could be why you're bugged.

But at the same time, the items should be appearing on all your characters (I made one last night after claiming my rewards on my main character and all my stuff was there except for the single-character only lock-boxes). Perhaps try finishing the tutorial on one of your characters, checking the store - and if that doesn't work try logging out on the menu by pausing, holding the left trigger, and pressing X. This particular method of logging out actually caused my Collector's edition items to appear, so perhaps it may help your stuff show up on your other character.

04-03-2013, 05:39 AM
I have the same problem, I started the tutorial with all my cool stuff and got stuck on the EGO power missions. Started a second character and it worked fine but no cool stuff, I have checked the store with my second character but I can't seem to find my stuff. Does it matter what store?

04-07-2013, 06:30 PM
+1 to above

04-08-2013, 12:28 AM

I'm having the exact same issues. Tried to start another character but all my Ark Hunter rewards or pre order bonuses.
I have filed a ticket and reported the bug. Haven't heard anything back yet but I refuse to play the game on another character and waste the time without all the things I should have already =/

04-08-2013, 12:45 AM
Try this: Abandon mission then re-accept and retry. abandon from the map.

04-08-2013, 08:12 AM
I am having this exact same problem! How do I abandon the mission from the map? I've been trying to proceed for days but keep giving up. Thank you!

04-08-2013, 04:13 PM
bring up the map. should say as first thing to press Y to abandon.

04-08-2013, 06:01 PM
Alternate FIX

Create a new character - open up the Radial Menu in game, go to the Store and look down at the bottom of the list you will see "Claim". All of your Ark Hunter and bonus pieces will be inside there =)