PDA

View Full Version : what is up with this game?



nope
06-13-2014, 07:04 PM
anyone notice massive lag, mobs disappearing, random disconnects, and when you get in a vehicle only to go a few feet and it eject you out? its starting to be a big turn off this is ridiculous

Bonehead
06-13-2014, 07:06 PM
I noticed that in April 2013.

Griffix8
06-13-2014, 07:07 PM
anyone notice massive lag, mobs disappearing, random disconnects, and when you get in a vehicle only to go a few feet and it eject you out? its starting to be a big turn off this is ridiculous
Yeah the despawns, lag, disconnects and stuff have been around for a long long time...

Atticus Batman
06-13-2014, 07:16 PM
I noticed that in April 2013.

I noticed in March during the closed beta and again a week later during the open beta.

Manstan
06-13-2014, 07:22 PM
I think this one makes 6.

Atticus Batman
06-13-2014, 07:27 PM
I think this one makes 6.

Probably but the new players and the former players with new troll acounts are flooding the forum with spam threads. Heck one guy ressurrected every Nim thread just to say he can obliterate Nim at ego 1k but had a hard time at ego 100.

nope
06-14-2014, 12:45 AM
i am new to the game so i noticed the issues

Dukhat
06-14-2014, 12:49 AM
It IS extremely annoying, especially during Arkfalls/breaks & Shadow War sessions...

They REALLY need to fix it. Often only thing that helps is dis/re-connecting OR wait 5-10 minutes.
BUT seeing as this has been an issue for so long, probably just bad coding on Turbine's end.