PDA

View Full Version : I swam from Silicon Valley to the mainland



clubside
08-08-2014, 11:12 AM
Most everyone knows Defiance has some of the worst network code of all time. Constant disconnects, dropped trying to enter the Warmaster, rubber-banding, dying from invisible enemies or missing scenery and more. I decided to try something new.

I'm one of those people with multiple characters stuck below 5000EGO because of the lame pursuits so I can't even access content I've paid for (Chimera stuff) so every time there's something new I hop on what I can to inch ever closer to the "goal". One of the problems doing this on console (none of these are issues on the PC version generally) is the diconnects as it's all too common to play an entire incursion and get dropped before the end wasting a lot of time (especially once you're past the XP cap). One of the new pursuits relates to a new kind of "incursion" in Silicon Valley. After not getting credit for three in a row I came to that wonderful situation where you're not dropped but the game stops responding, no information on the character screen, no locations on the map (ever notice how the map comes up instantly here but not when you are connected like it wouldn't make sense to display the local texture art instantly and then draw in the info grabbed from the server?). When you encounter this problem you can run around hoping to re-sync and maintain your situation or manually log out and hope you get back in before the event ends. Having lost credit three times I opted for the former.

From the far south of Silicon Valley with a score over 30k and one of those whatever they're called things destroyed the old rubber-banding started. Enemies and players were still running around but I couldn't switch weapons, realod or anything but watch the screen damage flash as I circled the area hoping for a re-sync. I pulled up the Xbox Live Guide. I pulled up the empty character screen and map. I ran further south away from any enemies to reduce the number of characters around. Nothing worked.

There were hints of connection as items on the ground flew from a quarter-of-the-map away but it was fleeting. I got to question the client-server relationship as I meleed enemies running in place and "killing" them but they're still running despite their armor and health bars going away and damage numbers appearing. Every few minutes my weapon swap would register but then not work again and a few more drops would fly my way. What to do? I've never been there for the end of one of these events I couldn't be sure I could log out and get back in time. So I headed north.

You've probably already spotted siege and other event indicators from the mainland as well as contract faction icons while in Silicon Valley. The creation of this area was a nice addition even if it was the lazy method of world expansion (as I suggested last year when offering examples of how to deliver content people actually wanted rather than mechanic changes nobody can stomach). But in true lazy implementation fashion it appears the developers just used the swimming limit restriction to wall off part of the open water to the far south of the main map rather than implementing an entirely separate area like the co-op and PvP maps offer. Given these indicators I decided to go for a swim with a hope on my mind: I'd drown and get re-synced and placed back in the heat of the event, my score intact.

Unable to rez a car I started to hoof it north. Occasionally item drops would fly from halfway across the map as I moved further and further away from whatever was cached client-side. I ran up mountains, to the areas with wandering NPCs (hello 7th Legion, so that's where you've been hiding). I made it to the coast and after running from end-to-end with no re-sync, I dove in.

From the norther coast of Silicon Valley you can actually elements of the mainland, some of those inaccessible ruins on the tiny islands, and the mountains. It shouldn't take long to drown based on the swimming rules we've all learned. But I kept going, no screen darkening happened, no need to jump across water, the mainland was getting closer. And I reached it. I pulled up the map and the main map appeared, something knew I was no longer in Silicon Valley. That same something didn't know I had two weapons to switch between or a vehicle to call. So I kept moving.

I could see the tops of the bridge in the distance. Will I actually be able to cross the whole of the game? As I continued to move and mull the possibility a transition screen appeared and I was back in Silicon Valley with the dark drowning effect going as I walked around. The other players finished the incursion shortly after before I could return to scene and I got my first result screen. Finally some credit lol.

I haven't been back on to check the pursuit progress yet. My other 360 install resulted in black textures with the update so I had to do a partial re-install. The PS3 version was fired up for the patch as well as both PCs. I figured I'd take a preparation break and recover from the sheer insanity of my adventure.

There's always something new to complain about in Defiance but I was happy to see a number of posts call the team on the carpet over on-going connectivity and memory leak issues which darken the console experience. That's anothr 5 EGO I can't earn since 75% of the time I'm disconnected trying to enter the WarMaster's arena and the other 25% he can't be beat with lock breakers who already have the pursuit only caring about their awards and kicking things off with a half-dozen players in the room. So I wanted to put the vitriol about the mind-numbing madness that is EGO Scaling or the horror that is all of DLC5 aside and post an example of how these networking issues impact play. But I can be constructive as well.

We've received a number of patch notes claiming better server communication but I have yet to see the result. How hard is it to ping the client every second and re-sync if the proper handshake is no longer established? I'm still connected to Xbox Live. I'm still connected to the Internet, why is Defiance's network code failing? How about a full re-sync when the EGO or map are opened? There's always a delay (on console) before either page is drawn, the client should know it's not getting the proper information and should bump the server to re-sync. There are obviously other checks-and-balances that could be put in place alongside whatever currently "occasionally" works to reestablish sync. Same thing with the WarMaster, I've never been disconnected entering a co-op, that's an isolated instance, why isn't the WarMaster on the same transfer code? If the game is going to remain available and we look past the mountain of wrong moves made by whoever is actually driving this bus, there is only one thing to focus on: stability. Stability of connection, stability of memory resources, stability of experience. EGO Scaling has rotted the game at it's core but ultimately that's a design mistake that sits atop a failed infrastructure. That foundation needs to be made solid before anything else really matters in the long haul.

So if you're in Silicon Valley and get the old "the game isn't responding" experience, don't log out. Go for a swim to the north. Peak through the draw-distance clouds to the half of the map no one wants to play on. It's a fruitless exercise, but it might also be the laugh you need.

Sevrin
08-08-2014, 11:29 AM
There are just some pursuits that don't suit me. But I love this game. Please see my signature line. Carry the message :)

Amack
08-08-2014, 11:46 AM
Hey Clubside, I haven't seen you post lately, welcome back.

Let me tell you, I went back and forth with the devs for weeks about this problem. We were experiencing the same exact symptoms on PC NA. I showed them network traffic graphs, I showed them pings, I showed them tracerts, and last but certainly not least, I showed them frustration.

This went on and on, patch after patch, until one day I ended up on my very own shard somehow (Still haven't figured that one out). After weeks of experiencing exactly what you are describing, all of a sudden I am on my own shard that is not getting any other players routed to it. I played for 6 hours non-stop by myself with not a single other player showing up on any event scoreboard. I was in absolute heaven. No lag at all. Not one disconnect in those 6 hours. My vehicle did not disappear. It was like I was playing an entirely different game.

I explained this to the devs and they moved on the information immediately. Since this last patch that everyone hates, I have been able to play for hours on end with no problems once again. They are working on player distribution and they are making good progress from where I am sitting. As we all know the platform populations probably differ greatly so they may have to make special changes in this regard to each platform.