PDA

View Full Version : A couple of questions.



billifred
08-21-2014, 11:09 AM
Okay. I have asked these questions here a couple of times and have received no productive answers.

1). The current patch version of the game is 2.204 (soon to be 2.205); when I login to play it says I am running 2.202 and there is no update. It is my understanding that nothing is downloaded because it is a server side patch. Even if this is so, shouldn’t it tell me that I am running on the current patch and not one from a couple of weeks ago?

Regardless of whether it is a disparity in communication or not, it leaves me feeling I am not running the current version because Trion’s software is broken and will not update my game to the current version.

2). My HUD (heads up display) overlay does not display chat text. The chat box has not worked at all since the Silicon Valley expansion was added over 2 weeks ago. Voice chat does not work either.

I have submitted fix it tickets through the game and I have asked for help and clarification on this site a number of times and the problem has not been fixed. It has not even been clearly addressed by anyone in any of the communication I have initiated. On the forums, I cannot find a definitive answer if there is one to be found.

N3gativeCr33p
08-21-2014, 11:10 AM
Funny, I was wondering the same thing last night when I logged in for 5-7 minutes of "awesomeness".

squidgod2000
08-21-2014, 11:35 AM
2). My HUD (heads up display) overlay does not display chat text. The chat box has not worked at all since the Silicon Valley expansion was added over 2 weeks ago. Voice chat does not work either.

Go into your settings and set colorblind mode (or whatever it's called) to something. It defaulted to an invalid setting when they added it, which messed up chat display. As for voice, apparently it's been buggy since SV (can't help there--turned it off 14 months ago and never looked back).

dramaQkarri
08-21-2014, 11:38 AM
As far as the version - the last 2 updates were server updates so you are running them - no way to not run what the server is giving you. The patch notes often do not get updated on time in-game so if you want to know what was updated look here:

http://forums.defiance.com/forumdisplay.php?41-Patch-Notes

The voice chat problem you're having is a known issue so it is being worked on, if Squid's suggestion doesn't work for you. Hang in there.

PhantasieTrion
08-21-2014, 12:09 PM
Hi Billifred


1). The current patch version of the game is 2.204 (soon to be 2.205); when I login to play it says I am running 2.202 and there is no update. It is my understanding that nothing is downloaded because it is a server side patch. Even if this is so, shouldn’t it tell me that I am running on the current patch and not one from a couple of weeks ago?

Regardless of whether it is a disparity in communication or not, it leaves me feeling I am not running the current version because Trion’s software is broken and will not update my game to the current version.


Are you on PC, Xbox or PS3 and which region (NA/EU)? And, which language are you using (English, French or German)? Im going to assume PC-US English for now.

The patch notes that are displayed are actually just a HTML file. As long as we are just updating servers, I can assure you that even if the patch notes arent displaying properly on your end, you are connecting to the most recent servers.

That said, if there are displaying 2.202 for you there is a problem.

This is the public URL for the US-PC patch notes. When you go to this link, do you see the proper patch notes displayed in your browser (the background will be white) or is it blocked for some reason?

http://update03.triongames.com/ch3-patch-notes/win32/live/ReleaseNote_en.html

Try that out and let me know.


2). My HUD (heads up display) overlay does not display chat text. The chat box has not worked at all since the Silicon Valley expansion was added over 2 weeks ago. Voice chat does not work either.

I have submitted fix it tickets through the game and I have asked for help and clarification on this site a number of times and the problem has not been fixed. It has not even been clearly addressed by anyone in any of the communication I have initiated. On the forums, I cannot find a definitive answer if there is one to be found.

Take a look at this thread (http://forums.defiance.com/showthread.php?162105-Zone-Chat-is-not-working-for-me./page4). There was a bug that some people experienced that sounds similar to what you are experiencing. We hope to have a fix for that going out next week (and it will be on PTS shortly)

You can also PM the dev who talks in that post (DeadGhost) if you want to confirm - I just spoke to him now and he said it certainly sounds like the same issue.

Sorry for the hassle.

--Phantasie

billifred
08-21-2014, 12:51 PM
Thank you for your prompt reply, PhantasieTrion. I am on the EU PS3 server. If there is any more information I can provide, please let me know.

When I looked at the link only the image was displayed all of the text was almost completely washed out. Although I am guessing that is irrelevant to my case as I am playing the game on console and not on PC.


Go into your settings and set colorblind mode (or whatever it's called) to something. It defaulted to an invalid setting when they added it, which messed up chat display. As for voice, apparently it's been buggy since SV (can't help there--turned it off 14 months ago and never looked back).

I have tried to adjust the settings, and have tried to revert it back to default settings but there is not way to change the settings on my end.

Odd enough, if i log into US server there is no issue. The problem there is all of my friends and clanmates are on PS3 EU server.

DeadGhost
08-22-2014, 08:26 AM
Hey bilifred, sorry to hear about the issues you're experiencing.

As for number one, I'm not exactly sure what's happening. My best guess is that it's some kind of caching issue with the version number itself because if you truly had an older version of the client, you would not have the colorblind settings or chat timestamps. If those are missing from your chat settings menu, then yes - you're somehow running an older version. However, if that were the case I'd expect you to be crashing all over the place due to missing assets or handler functions for the newer messages that the server is sending to the client. If you're on PC and want to be sure you have the latest client, you can go to the directory where you installed Defiance and delete your client.exe file - Glyph does an integrity check on your client every time you push play and will re-download a new version of the exe if anything's wrong.

Number two has two potential known causes, both due to settings that got jumbled up in the latest client patch. First, try adjusting the chat text size. If that doesn't work, I'm afraid the other answer is to wait a few more days for the next server patch - I've put in a fix that will restore the corrupt config data that caused it.

If you're on console, voice chat functionality should have been restored with the last server patch - if not, I can look into that for you. If you're on PC, double-check that all your chat muting / push-to-talk / audio settings are what you expect them to be - the same bug that caused the missing chat box also may have jostled some of your settings around.