PDA

View Full Version : I hope the show is better than the game....



Izaho
04-03-2013, 07:07 PM
I have about 6-8 hours in the game. I bought it to play thru with friends. These are my thoughts YMMV of course.


All these issues have occurred over hours. After re launching the game and even re booting the 360. These are not isolated. They have happened to me and friends:
- ATV won't spawn. I have to log out and back in to make it work
- Group request don't work most of the time. I have to send 4-5 group request before my friend gets it
- After a cut scene he or I see the players in our group as a green square. The player is not there. I have to use "travel to friend" to see them
- I have had friends just disappear and the green square appears. They say they can see me. Same has happened in reverse
- Major lag. Enemies jump around all over the place (not always bad but noticeable)
- Items not spawning. I have had a friend tell me there was an ammo box right next to me..nope.
- I fast traveled back to the main camp and nothing was there. No people..no ammo boxes etc.

The game just feels rushed. Like I said YMMV but so far this is a major let down.

Myst
04-03-2013, 07:09 PM
By chance what system are you playing on? I noticed a few 360 players and quite a few PC players are stating these problems.

Dagbiker
04-03-2013, 07:15 PM
It sounds like what your having is connection issues with a side of over hyped expectations. When a million people are on screen I also get some pop in.but I realized the bugs were burrowing underground. it just wasnt playing an animation. or something.

Izaho
04-03-2013, 07:39 PM
Myst, I am on Xbox 360.

Dagbiker, No over hyped expectations here. These are bugs and issues with the game. They are happening to multiple people over hours of play.

Kain
04-03-2013, 07:49 PM
I am experiencing several issues with the servers as well. Granted they may just be connection issues but my vehicle doesn't spawn half the time and when it does it spawns in a random direction (not where I was facing) and usually on debris. Major lag with enemies and quests. With the races I spawn 7-8 seconds in the race and the vehicle won't move. I've logged out and logged back in over a period of several hours today and as of now the game is unplayable for me :/. There goes all my xp boost.

Myst
04-03-2013, 07:51 PM
Myst, I am on Xbox 360.

Dagbiker, No over hyped expectations here. These are bugs and issues with the game. They are happening to multiple people over hours of play.

Ah understandable then I know for the beta there were a few problems plaguing the 360. I personally haven't run into a whole lot but my case will certainly not be the same as others. Hopefully with the times they take the servers down and fix things that eventually they will come to the solidifying the coding so that it won't hamper as much.


I am experiencing several issues with the servers as well. Granted they may just be connection issues but my vehicle doesn't spawn half the time and when it does it spawns in a random direction (not where I was facing) and usually on debris. Major lag with enemies and quests. With the races I spawn 7-8 seconds in the race and the vehicle won't move. I've logged out and logged back in over a period of several hours today and as of now the game is unplayable for me :/. There goes all my xp boost.

I noticed that myself, I was looking straight ahead and tried to spawn my vehicle and somehow it got on top of a crate to which I couldn't reach. Also I think with some problems they (hopefully) will extend some of the boosts for those who have had problems.

Izaho
04-03-2013, 08:02 PM
I should have said that as well. Same issue with the vehicle.

Kain
04-03-2013, 08:03 PM
I noticed that myself, I was looking straight ahead and tried to spawn my vehicle and somehow it got on top of a crate to which I couldn't reach. Also I think with some problems they (hopefully) will extend some of the boosts for those who have had problems.
Hopefully, After the first patch they did yesterday things kinda went downhill for me. Last night things were going fairly well but now that I try to play today things just don't want to work. But they seem to be working on fixing things so things should turn out okay.