View Full Version : Story Mission: Safe No More is broken

Chaos 915
04-04-2013, 08:00 AM
During the last step of this quest where your supposed to defend the miner with a pulverizer. I finish doing that but the story won't progress. The final wave of enemies just spawn over and over again. So I can't progress the story missions.

I was in the middle of this mission last night at about the same point I got stuck at now, so it may have somehow been glitched because of that.

I getting tired of this mission.

04-04-2013, 08:07 AM
Likewise, Sniper Ridge appears to be busted. The ammo caches won't spawn and the area is empty.

Chaos 915
04-04-2013, 08:13 AM
On my third attempt today (fourth if I count yesterday) It finally worked. It may have to do with me skipping the cutscenes, because the third time I didn't skip the cutscenes and it finally worked.

07-11-2013, 09:45 PM
Still bugged - i left beta and this was bugged return 3+ months later and its still bugged.

Can not progress, enemies keep respawning, game is merrily playing away in the background with my char emote danceing & I'm searching the forums now typing this.
Turrets are killing mobs fine just fine, miners are walking around as if on holiday, cob is screaming pointless crap....
I've tried logging out, then exiting/restarting but i return to be still mid quest & bugged, same old shatko going on.

Trion stop playing with your jondaras and fix this.

10-27-2013, 03:36 AM
It took us 2 runs. At the 2nd we skipped all the cutscenes and it worked.
We abandoned the mission and restarted the game.