PDA

View Full Version : Project Aegis Part 1, Can't activate turrets, (resolved...sort of...)



xeaon
04-11-2013, 10:04 AM
Last night I ran into that mission (Project Aegis Part 1, Can't click turrets) I was not able to activate 2 turrets out of 4.
I saw some players around me having the same issues, but since the chat is still half working, ppl were not incline to communicate about there own failure.

Today I tried again and figured the issue.

There is "walk in" missions next to the turrets, that interfere.
For instance on the 3rd turret there is the mission "Car Jacked" right next to the turret, once you complete it, you can finally activate the turret.

so anyway, I figured ill share my finding!

Solletico
04-11-2013, 11:14 AM
its not just walk in missions, sometimes there are enemies glitched inside the nearby vehicles so you cannot activate the turrets, also on the last turret there is about 3 random missions or other NPCs stopping you from activating it, which includes a hulker and a monarch, good spot to farm some kills though, especially for the contracts