View Full Version : My fifth perk keeps getting unequipped

Alcohol Fueled Brewtality
04-12-2013, 08:39 AM
It doesn't matter what I put in there once in a while when I check my Loadout, to perhaps change a weapon, the fifth slot keeps going blank. Doesn't matter what I put there.

04-12-2013, 08:41 AM
Same thing here with my 6th perk i notice it happens in loadout 1

Alcohol Fueled Brewtality
04-12-2013, 08:43 AM
Is that your last unlocked slot? Fifth is mine, you see. I guess it only happens to the slot you unlocked last...

04-12-2013, 08:43 AM
It's a known issue. Hopefully it will be fixed soon!

04-28-2013, 07:36 PM
This is really getting f'n old now after a month. I've tried redoing all perk load outs on all the different load outs. Tried swapping outfits after changing perks, tried changing load outs after I loaded the perks and none of it saves the perks. Sure it'll show the perk when I hit K. Sometime after I zone into a coop instance though it just unequips itself randomly. It's always the last unlocked slot. It's been happening since I unlocked my 4th slot and currently happening on my 5th slot. It's as game breaking as the reloading bug and needs to get fixed this week not next month.

04-28-2013, 07:40 PM
It's a known issue. Hopefully it will be fixed soon!

Yeah, it's well known since February, alpha stage. So..soon...

04-28-2013, 08:05 PM
That happened to me aswell. I equipped the perk directly from the grid instead of clicking on the slot in the loadout, and after that it never unequipped again. I hope it works as it did for me :)

04-28-2013, 08:10 PM
Some of my perks unequip as well.

04-28-2013, 08:29 PM
As a side note perks are missing when you are changing a gun in your loadout.

04-28-2013, 08:45 PM
The earliest I've seen it show up is the 4th perk slot. So far I've had it happen on 4th, 5th and 6th, and it's always the most recent slot you've unlocked. I'm not sure if it happens on the 7th or not, I've not quite got that far. :)

04-28-2013, 09:27 PM
Yep tends to happen with everyone, known issue, your not alone.