PDA

View Full Version : NA Server down?



Flak
04-14-2013, 06:59 PM
Tried to play again after taking a break from the lag, launcher won't progress after hitting Update.

Wadgod
04-14-2013, 07:01 PM
not down in right now, some ppl complaining of lag but server is up

Tahlyan
04-14-2013, 07:01 PM
Glad someone else is having problems. Just started playing today and nothing but issues. Enemies and allies and vehicles just disappear mid combat. I cant finish quests and have done the same one three times in a row. I cant spawn my own vehicle. I keep getting teleported back to the same place when I log back in. And the game has crashed 4 times. This is not a very good first impression. Is it better normally?

Drakkenfel
04-14-2013, 07:17 PM
It usually performs real well for me. I am on nearly every day.

Defy
04-14-2013, 07:29 PM
not down for me

xxShark
04-14-2013, 07:45 PM
down for me. has been for about 2 hours now.

EDIT: working for me again.. Central US

DrFeelzgud
04-14-2013, 07:47 PM
Cant get past character screen myself. Get the Critical error - connection timed out message. It usually runs great for me.

Edit: Nvm I just got in.

Daknoe
04-14-2013, 07:51 PM
im having the same problem, i get to character screen try to load into server and get a critical error saying the server is down.

JohnnyWakler
04-14-2013, 08:03 PM
I am stuck at the character screen. Server times out when I try to load into the game.

sp00s
04-14-2013, 08:18 PM
I had a little bit of lag a while ago, but wasn't disconnected or anything, maybe the log in servers?

Ryback
04-14-2013, 08:18 PM
I too just tried to log on and cant get past the welcome screen into the game. Said server is down and try again later.

Agonist
04-14-2013, 09:24 PM
http://forums.defiance.com/forumdisplay.php?35-Defiance-Server-Status

Resgate
04-14-2013, 09:36 PM
http://forums.defiance.com/forumdisplay.php?35-Defiance-Server-Status

Not really helpful when the last update by the admins was two days ago. Seriously though, I've been trying to get in all day and all I get is the server down message. VERY irritating.

Baerrwin
04-14-2013, 10:35 PM
Currently can't connect. It shows my characters, but won't allow me to log any of them in. It says that the connection times out. Hopefully the patch will fix it.

Agrona
04-15-2013, 05:40 AM
Well, at least it wasn't just me. My game totally bugged out. I experienced increasing lag, to the point where my inventory and load outs showed completely empty. Then I logged out and tried to get back in, but the connection timed out.

I've played a lot of MMO's and I know what lag is, but this? I never experienced anything like that. Plus, Defiance has run fine for me so far.

The bad part though is that when I was finally able to log back in, my purple assault rifle was gone. It was pretty much the only gun I used and I was quite fond of it. Everything else was there though. Oh well, it was just pixels on a screen. LOL

Cruize
04-15-2013, 07:42 AM
It doesn't even let me see my characters, after logging in and clicking "update" it just goes into a Fetching versions loop and then an error. patch aborted one. >.<

EDIT: Had to reopen and close the client and it worked... randomly :O