PDA

View Full Version : Some please tell me how to stop my mouse from over compensating I cant target



Khazgul
04-19-2013, 05:54 PM
Some please tell me how to stop my mouse from over compensating I cant target, I turn it a little to the right and flies off to the right try to turn it back and flies the scene way to the left. I cant target anything before I am freaking fragged by the mob bc I am too busy playing find out which way your facing just to get spun in some other direction. I know this is probably my pc but as far as I can tell there is no settings in the game adjust this. I really feel horrid bc I was looking for something to replace wow but they have the best game engine ever and I think all other games need to learn from them this is crazy. I read the forums and people are having a fun time in this game please by all means help me like this game I feel like the TV series made me waste my money at this point ugg

Mirimon
04-19-2013, 05:55 PM
try turning down sensitivity in game, or in windows under your controller settings, also.. take off aim assist.

also.. I wouldn't exactly replace any game with defiance.. even a horrible one like wow (minecraft looks better than wow....) but really.. if you are actually looking for an MMORPG to replace WoW.. play Rift.. the developers came from all the mmorpg's ever made (the good ones) and brought all of what made those good with them into a melting pot of gaming.. rift sets the bar on mmorpg's, as it not only looks and plays really good, but takes less hardware requirements and costs less. It also doesn't have as much hand holding as wow does, so there is some sense of adventure in gaming again.

Rahziel
04-19-2013, 05:56 PM
if i was having that issue, which i had at first, go into settings, (menu, hold space, settings) go to controls i believe, and there is a mouse sensitivity option, adjust to you pleasure

Igneus
04-19-2013, 05:57 PM
Under Settings go to Controls. There is a Mouse Sensitivity slider bar. See if that works.

Dazz
04-19-2013, 05:58 PM
There is a mouse sensitivity setting in the 'Controls' menu. That might make it all wonky if its turned way up. Mine is set to 1 block. You might want to change mouse sensitivity in windows too. Mine hasn't been twitchy, but it was kinda too fast at first. I think mine was set to 4 boxes initially and was a little more controllable when I toned it down some.