PDA

View Full Version : Possible sound fix.....



DamianThorn
05-10-2013, 12:54 AM
I have read several folks talk about their sound messing up,and causing a complete restart to temporarily fix the issue.
I myself have had the sound issue,and went about trying to find a solution...to which I may have found.

Since doing this,I have played the last 3 nights with no sound issues what-so-ever.

1-go into sound settings on the PS3 xmb,and DEselect everything that is currently selected. There will be 2 audio settings that you cannot deselect,so those will be the only 2 that will be left.

2-go into the game menu and disable combat music (it doesn't work anyway)

Doing these 2 simple steps,it seems to have stopped my sound issues,and I no longer get the "metallic fan sound"

If you are running through a sound system,I'm not sure if this will work or not...but since I'm only using my T.V speakers,it seems to have corrected the issue.

Hopefully those of you that have had this issue will find this helpful.

fr34kyUK
05-10-2013, 05:21 AM
Thanks will give it a try tonight :)

chrismeyer34
05-10-2013, 05:23 AM
yeah i had an issue with the " helicopter sound " too, drove me nuts, but its all fixed and all

AmnesiaHaze
05-10-2013, 05:30 AM
it worked before the patch, so im expecting it to be fixed without having to mess with my audio settings which are perfectly fine for ALL other games

Facade
05-10-2013, 09:22 AM
If I only played this game I may have changed the sound settings but I play too many games through my SS to be changing all my settings back and forth.

Good find though, just not for me.

METAL GRINDER
05-11-2013, 03:43 AM
I don’t want to touch my XMB settings, but will work with the sound setting in the game. It is worth a try, thanks.

Mad39er
05-11-2013, 05:52 AM
Turning off Combat Music works. Game needs to be restarted for it to take effect for me but it seems to resolve most of the sound glitch. I still hear a hiccup here and there but my sound hasn't died or got choppy since turning off Combat Music.

Dog4life
05-13-2013, 12:16 AM
I realized the sounds dies only with optical dolby sourround... total mute and corrupted.

Using normal TV speaker, sounds thourgh HDMI, no problems.

I hope they realize its fault of the new patch and will fix it. Trions gave me standard answer to reinstall patch....

AmnesiaHaze
05-13-2013, 04:20 AM
i agree , im not going to switch back and forth between my sound system and tv speakers just because of this game , it works for every game i have , it even did for this one before the latest patch

Assasino
05-13-2013, 04:53 AM
I never really had issues before the patch (even chat worked awesome) and well we all know what the patches have done.
I will give it a try, thanks for posting

DamianThorn
05-13-2013, 07:33 AM
I appreciate the responses,for the record though....I understand those of you that use sound systems and not wanting to change the settings each time.

This was mainly a fix for using regular TV speakers. I have been using this same setup before and since starting this thread,and have not had any sound issues.

I would love to be able to use my sound system,but unfortunately apartment living pretty much makes that null and void...and besides,my wife wouldn't take to kindly to the "ruckus".....lol

Rokea
05-13-2013, 08:10 AM
I never play with the game music on anyway, however I still have that sound issue plus the glitch where the sound drops out entirely.

Facade
05-13-2013, 08:21 AM
I realized the sounds dies only with optical dolby sourround... total mute and corrupted.

Using normal TV speaker, sounds thourgh HDMI, no problems.

I hope they realize its fault of the new patch and will fix it. Trions gave me standard answer to reinstall patch....

Now this may be on to something though, I haven't had it really happen when using anything connected to HDMI, only Optical (for my headsets)

Facade
05-14-2013, 11:45 AM
I never play with the game music on anyway, however I still have that sound issue plus the glitch where the sound drops out entirely.

Yea I'm starting to do this now. Last night I had it do the metallic sound about 30 min after logging on, then after restart it started again within 10 min, then it stopped after about 20 min, then started again about 10 min after it returned.

At that point I moved the sound to 100% voice on my mixamp and gave up on trying to have the game sound at all.

Rokea
05-14-2013, 01:29 PM
I just started playing with either pandora or slacker playing... my stations sound better than the game music anyway.

Colif
05-14-2013, 07:36 PM
Turning off battle music seemed to extend the period before my sound dies at arkfalls, but turning all sound off altogether isn't a good solution, as I also find that after the sound dies, the game often disconnects me from psn and I have to restart ps3 to actually play again. Something is wonky with the way the sound is broadcast since last patch. I am used to ego being slow with telling me stuff but this is annoying. It only happens at big arkfalls where there are heaps of people around.

Yes, I use digital speakers. I could use tv ones but that is wasting my surround set up.

Dog4life
05-16-2013, 12:11 AM
All i can suggest all of you , flood the trion support with this issue, so they MAYBE finally understand that is a general issue !

Trionsupport does not listen to my tickets, and only answers to reinstall patch.....

Also theres a thread in bug report section, more comments = more attention = hopefully they fix it !

--> I can confirm for sure now audio issue is related only to optical output. I played for over a week now almost only on the TV speaker with HDMI --> never any audio issue.
Well sucks i cant use my dolby sourround system for now.... but anyway i need keep audio low if using voice chat

NoahsArkfall
05-16-2013, 02:48 AM
I have this same issue with Black Ops II every once in a while, especially during marathon gaming sessions...which I'm prone to having.