PDA

View Full Version : Lag / Game performance -- are you lagless? Need tips.



AgentSpiff
05-14-2013, 12:22 PM
I'm having a lot of fun with Defiance, but I've been suffering a lot of lag in certain ways that is seriously detracting from the game... Particularly when driving around at high speed and then, of course, in the big Arkfall battles.

One of the things I thought immediately when I first heard of Defiance being an MMO FPS was: Lag. MMO's invariably suffer from lag but twitch gaming requires a nearly lagless environment. I just didn't see how Defiance could properly pull it off if the servers and the players were not both hooked up to the same Google net hub or something.

I don't live in a Google town and I dont know where Defiance servers are located.

Needless to say, lag is really a problem.

Does everyone else struggle with difficult lag while doing fast driving like when attempting time trials and such? The lag makes it really hard for me to maintain absolutely smooth control of my vehicle for the kind of precise steering that you need to hit each ring precisely while setting up the next ring down the line.

Yet people have really amazing times on those trials.

Does anyone else have a fairly lagless experience?

If it's possible to get glassy smooth performance in this game, I could use some tips.

My video card is kind of old but I'm not sure that's the problem ... most gunfighting is pretty smooth for me. Sometimes choppy lag kicks in and makes it hard for me to spin and line up a target sharply. But for the most part I'm able to get good frames. Is there a frames per second readout in the game?

I've tried turning graphics all the way down in the game (still at 1900x1200) but still get really choppy lag while driving time trials.

My thinking is that what's causing the lag is network delay in loading new mobile objects as my visible horizon moves around the country side. That would explain both the driving lag and Arkfall lag.

In large Arkfall battles I do get bad frames per second... monsters stutter frame, probably close to a handful of frames per second.

Anyway, if you have glassy performance with this game, I'd like to hear about your performance. Alternatively, what should I look to upgrade to get a better experience in this game?

My System is getting on the oldish side:
- Vista 64
- 8Gb RAM (don't remember the RAM type)
- Athlon 64 6000+ dual core 3GHz
- Mobo: Gigabyte M57 with PCIE x16 video slots
- GeForce 260GTX (4Gb RAM) (only one card)
- Network = Time Warner cable -- Speedtest.net averages 26Mb/s but it looks after the burst cache fills up I'm getting more like 10Mb/s.

I'm thinking that this gear should be adequate for Defiance and that the problems are bottlenecking on the server side. But I'd like to hear people's thoughts.

Thanks.

-s

Arsenic_Touch
05-14-2013, 03:14 PM
4 gb of ram, a 5770 and a Q6600 and I have no lag. There used to be lag problems but that's about the only thing the fixed.

Don't look at time trial leader boards as more than anything than a number, some people glitch their way to the top.
There is a slight server side delay which will add a few seconds of time to your total, but the major problem with time trails is if you fail and restart, it will add anywhere from 5-16 seconds to your total, so if you fail, it's best to restart, then cancel and quit so you spawn at the race point and start it over from scratch.

So if you're having lag, might be out dated or unoptimized drivers, or your network is giving you problems.

Miles_Morales
05-14-2013, 04:25 PM
I play on a $300 laptop, so i feel your pain.

Some tricks I found:

1. Adjust resolution/ turn full screen OFF

2. Turn shadows/bloom/blur OFF

3. Update DirectX and Graphics Card drivers

4. Change your battery settings to "High Performance"

5. Close your other programs

Hope some of these help!

Dazz
05-14-2013, 05:53 PM
I have no lag on my older desktop that I can tell. It is a wired connection into my router.

Gateway LX6820, Core2 Quad / 2.67GHz, 8 GB RAM, NVidia GTS 250.

My laptop is an Asus G53SW gaming system, i7, 8GB ram, NVidia GTX 460M over wifi and its laggy as hell. Arkfalls are miserable and even my ATV can take 5 or more seconds to rez.

Lappy was always better in WoW and Rift than the desktop, but not so with Defiance.

KeevanSixx
05-14-2013, 11:27 PM
running on hp entertainment laptop, 8g ram, my lag comes from using satellite internet....it's the only thing i can get out in the sticks. I avoid timetrials and most hotshots due to extreme latency, and painfully chop my way through arkfalls. setting are all low, so i know it's not my graphics card (updated all my graphics and hardware software, so i know it's not these) that just leaves the huge gap in sending and recieving packets over a satellite connection. Could probably be fixed if someone at trion figured out how to shorten the packets a bit. Had the same problems over at GW2 for awhile until a portion of the playerbase asked them to figure out a way to shorten the packets and telemetry data so users on satellite ISP's and older systems could play near flawlessly (well, as near flawlessly as we could at any rate....still chopped a bit during world events, but not as bad as in game currently) as it stands for me right now, i can show up at an arkfall, and nothing loads for about a minute game time, but everything and a mosquito can crit me off the bat without ever seeing them (got pounded by a monarch into oblivion and i never saw it for a full minute or more), most emergencies and arkfalls take a bit to load up for me.....it's sad.....but i manage (could be much better though).

Glacian
05-15-2013, 09:02 AM
A get a lot of lag that I'm pretty sure is server side (I have no issues like this with other games). No framerate problems, not even on my old 9800 GTX that I just burned up.

Snickers012
05-16-2013, 08:58 AM
On my PC (i5 2500k @ 4.5Ghz, 8GB 1600Mhz, AMD 7950 @ 1.1Ghz) i get around 1 second added to all time trials i also have 60Mb cable broadband and have a ping of <50 to most places in the UK.

Your GPU and RAM seem fine have you thought about ugrading your CPU that's probably the biggest bottleneck on your system. Your internet seems fine a little lag is expected in most games but i would say CPU is slowing your system down overall. Try what miles said turn afew setting down to increase performance and disable any programmes in your taskbar that your not using. See if that help's if not time for an upgrade maybe.
I hope some of this help's.

Blak
05-16-2013, 12:55 PM
I recently built a new machine so I have 0 performance delay.

It sounds more like a RAM issue honestly, but with any dated computer fixing one thing wont do much for you. it is like putting a super charger on an old car without putting all the other parts to support the new power. You will just slow down your new RAM to the performance of your motherboard and CPU.

Overall it just sounds like it may be time to save up for a new machine.:(

CptBadger
05-16-2013, 06:26 PM
My System is getting on the oldish side:
- Vista 64
- 8Gb RAM (don't remember the RAM type)
- Athlon 64 6000+ dual core 3GHz
- Mobo: Gigabyte M57 with PCIE x16 video slots
- GeForce 260GTX (4Gb RAM) (only one card)
- Network = Time Warner cable -- Speedtest.net averages 26Mb/s but it looks after the burst cache fills up I'm getting more like 10Mb/s.

I'm thinking that this gear should be adequate for Defiance and that the problems are bottlenecking on the server side. But I'd like to hear people's thoughts.


Your rig is really old. That CPU is no good and is your major bottleneck. So basically all you can do is lower the details and upgrade your PC.

That being said, game could still use some optmization.

Zulli jr
04-06-2015, 03:47 AM
I was playing on a PS3, but that was no longer an option, so I had to switch to a PC. Unfortunately, my computer was old. I had played Warcraft and lots of other games on it without any problems. I didn't think I'd have a problem. I loaded up Defiance, but was getting waaay too much lag. The video was choppy and it was pretty much unplayable even at the lowest video settings. I mostly gave up trying as I adjusted settings with the video and my connection, but nothing was working. I even reformatted the comp, but it didn't help. During the course of reinstalling all my software back on the computer, I remembered that I had this thing called Ashampoo WinOptimizer 2013. It has a section to tune my internet connection, so I set all that to the suggested settings for Warcraft that are noted in the program. It worked and now my video is clean without all the lag and I can get back into the game. I'm using the 2013 version. There is a new version that one of the selling points is "Game Booster." I don't know if that does the same thing, but I assume that it still has the separate section for tuning the internet connection. Also, they do offer a Free version, but I don't know if that includes the net tuning. I would suggest starting with that though.

WhiteStrike
04-06-2015, 03:48 AM
I was playing on a PS3, but that was no longer an option, so I had to switch to a PC. Unfortunately, my computer was old. I had played Warcraft and lots of other games on it without any problems. I didn't think I'd have a problem. I loaded up Defiance, but was getting waaay too much lag. The video was choppy and it was pretty much unplayable even at the lowest video settings. I mostly gave up trying as I adjusted settings with the video and my connection, but nothing was working. I even reformatted the comp, but it didn't help. During the course of reinstalling all my software back on the computer, I remembered that I had this thing called Ashampoo WinOptimizer 2013. It has a section to tune my internet connection, so I set all that to the suggested settings for Warcraft that are noted in the program. It worked and now my video is clean without all the lag and I can get back into the game. I'm using the 2013 version. There is a new version that one of the selling points is "Game Booster." I don't know if that does the same thing, but I assume that it still has the separate section for tuning the internet connection. Also, they do offer a Free version, but I don't know if that includes the net tuning. I would suggest starting with that though.

Dude,necro.

Shotora
04-06-2015, 05:31 PM
My System is getting on the oldish side:
- Vista 64
- 8Gb RAM (don't remember the RAM type)
- Athlon 64 6000+ dual core 3GHz
- Mobo: Gigabyte M57 with PCIE x16 video slots
- GeForce 260GTX (4Gb RAM) (only one card)
- Network = Time Warner cable -- Speedtest.net averages 26Mb/s but it looks after the burst cache fills up I'm getting more like 10Mb/s.

You are practically on same thing as me with exception my video card is better and you have more ram. in large events im pulling 15-20 fps im ofcoarse used to it been here a year nearly and face low fps in events naturally outside of an event it runs fine 40-60 fps (i lock it at 60 with radeon pro)

This game is more CPU needy and we both on old athlons same exact one ima tell ya its holding us back this game craves CPU power rather than GPU most MMO games do it's not like sp games they aren't as needy on CPU as GPU with exception of RTS games.

Only advice i can give you run low or medium settings I dont like way my atvs look at low but it will run helluva lot less laggier if you drop that low i run on medium settings most the time with motion blur bloom and shadows off If you haven't tried shadows off do so it's nasty on us old athloners you will see huge increase in fps and lot less lag without em.
Get you an FPS deal fraps msi after burner and look to see if its lag or low FPS sometimes it's easy to mix them up. I face much more fps lag then i do server lag I'm on 20MBit net like 2mb/s down and 200kb/s up I havn't critted out since aug 2014 I've seen some serious lag spikes but no errors.

This my specs
vista 64
Athlon x2 6000+ 3.11 GHz
4GB ram
Radeon R7 265 (Slightly better than 7850HD)

My mobo bottlenecks the GPU it was designed for pcie 3.0 my mobo only pcie 2.0
This pc over 9 years old I'm amazed it does the game as good as it does and any other 2011-14 game anyways lol

Doubt it does to well on unreal 4 engine that is soon to come out this year probably need me an upgrade soon lol