PDA

View Full Version : Need help



BoomyKilleR
05-24-2013, 05:21 PM
Can you guys play Defiance, everytime I try to download the new patch it keeps saying after it done installing it that the patch failed. Am I the only one with this or is a lot of other people having this trouble?

poisd2strike
05-24-2013, 05:39 PM
Can you guys play Defiance, everytime I try to download the new patch it keeps saying after it done installing it that the patch failed. Am I the only one with this or is a lot of other people having this trouble?

See my response here: http://forums.defiance.com/showthread.php?75455-Critical-Error-After-Last-Patch&p=692930&viewfull=1#post692930

BoomyKilleR
05-24-2013, 05:53 PM
Ok, Thanks.