PDA

View Full Version : Randomly Unequipping Perks



Ashlocke
05-25-2013, 11:33 PM
Simple bug I've noticed, the last perk in my perk list will spontaneously unequip itself leaving the perk slot empty. It will happen on any one of my 5 loadouts, seems to be random which. But it's always the last perk in the list that gets affected. I've gotten a few perk increases over time, I.E. 3 perks total, 4 total, 5, etc. and in each case the one that vanishes is always the last one in the list.

As for how often it unequips itself, I'd say a few times during an hour's worth of play.
Basically I will equip XYZ perk into the last slot, play for a bit, and during that time I will open the loadout screen several times until at some point I will open the loadout screen and see the perk has gone missing from that slot. This means that I always look each time I open the loadout screen so that I know it's not every time I do so that it goes missing, ballpark estimate it happens around every 10th time I open it, roughly 15-20 minutes real time, or several times in an hour.

Wolfhound
05-26-2013, 04:24 AM
Same here. But it's always the first loadout. Happens after every log-in and+ entering or leaving a coop-mission.

Ashlocke
05-26-2013, 06:03 AM
Now that you mention two causes, I have been paying attention to each time I log in and behold! The bug strikes a random loadout each time I log in. Good catch. As far as coop maps go, I haven't run one yet, but I will be sure to pay attention when I exit them from now on.

Oh and I still get the random unequip just driving around and shooting mobs on the main game. It's not limited to the two causes you mention for me.

chewyzero
05-26-2013, 06:51 AM
Now that you mention two causes, I have been paying attention to each time I log in and behold! The bug strikes a random loadout each time I log in. Good catch. As far as coop maps go, I haven't run one yet, but I will be sure to pay attention when I exit them from now on.

Oh and I still get the random unequip just driving around and shooting mobs on the main game. It's not limited to the two causes you mention for me.

Add death to this list. I get this upon death quite often.

Ozcorp
05-26-2013, 08:43 AM
Yeah one would anticipated it would been fixed by now, yet it's still there.

Ashlocke
05-26-2013, 10:45 AM
After some more digging, I've noticed that it happens every single time I zone, whether it's into a coop or exiting a coop, or solo instanced missions, etc.

NirvanaDest
05-26-2013, 12:30 PM
This is a known bug thats been ni the game since beta. After you level up a bit it stops, then it starts again when you get a new perk slot.

Ashlocke
05-27-2013, 05:42 AM
I didn't know the bug has been around that long, I only recently noticed it happening to me, around the time I hit 2000+ EGO or so.

Ah well, that's unfortunate. :(

BladeRunner
05-27-2013, 07:07 AM
Yeah I've been having this problem too with my 5th Perk Slot. Doesnt matter the loadout, after every multiplayer match I play I have to re-equip my 5th perk slot.

Psamion
05-27-2013, 02:25 PM
Got to 4000 ego rating and not only do I need to re-equip the 9th perk every time I log on or change map but I still need to re-equip the 8th one as well. I was hoping it would only happen to the last one but guess not.

toffeecreme
05-29-2013, 12:14 PM
had this problem with all events stated above as well as changing weapon and/or outfit

DarknessEyes PT
05-29-2013, 03:18 PM
Thats a protection.
The problem is not on perks, the problem is the ego rating messages.
I get:
1) "Ego rating 800, +4 inventory slots, etc".
2) Perk archived at ego 1000 is unequipped because the ego rating is under 1000.
3) "Ego rating 1100, +4 inventory slots, etc".

That happen when i login, join or leave co-op/pvp

hoorah
05-30-2013, 06:55 PM
Thats a protection.
The problem is not on perks, the problem is the ego rating messages.
I get:
1) "Ego rating 800, +4 inventory slots, etc".
2) Perk archived at ego 1000 is unequipped because the ego rating is under 1000.
3) "Ego rating 1100, +4 inventory slots, etc".

That happen when i login, join or leave co-op/pvp

Exact problem I am having, when I login, and when I enter, then when I leave a pvp match.

Ashlocke
05-31-2013, 09:39 AM
Thats a protection.
The problem is not on perks, the problem is the ego rating messages.
I get:
1) "Ego rating 800, +4 inventory slots, etc".
2) Perk archived at ego 1000 is unequipped because the ego rating is under 1000.
3) "Ego rating 1100, +4 inventory slots, etc".

That happen when i login, join or leave co-op/pvp

That's an astute observation, good catch. I will keep an eye out whenever I see those messages and check my perk slots afterwards.

DrFeelzgud
06-01-2013, 05:24 PM
Yes, I've been pulling my hair out with this one. It's particularly annoying when playing PVP. You think you have a perk on that you don't.

After reading some of the reasoning in this thread, I'll have to pay more attention to what is causing it. I'm wondering if all the dying, spawning and teleporting to captured sites in Freight Yard may trigger it. If so, I need to watch it even more and see which ones may or may not trigger it.

It's really annoying me though, wish they get this one fixed!

Whiffmeister
06-02-2013, 03:44 AM
It's not quite random for me. It's always the last perk slot of the last active loadout that disappears when I log back in again. Doesn't happen when I fast travel but if I exit game or log out and then log in again. The last active perk slot of that loudout is empty and I have to re-equip again.

Ashlocke
06-03-2013, 05:32 PM
Yay, apparently there's a fix for this in the June 5th patch coming up. *Crosses fingers*

Link:
http://forums.defiance.com/showthread.php?83739-Patch-1.021-Discussion