+ Reply to Thread
Results 1 to 2 of 2
  1. #1
    Member
    Join Date
    Dec 2013
    Location
    Canada
    Posts
    54

    North American server not connecting

    Hi,
    OK, so haven't seen any post lately regards to the NA server login issues that many were having just days ago.... Well I can't get on to the NA server at all (I tried for hours...ports open using high speed cable internet). Yet I have NO issue at all logging into the UK server (NONE!!!). Why? And is this happening to others? And are these types of connection posts being deleted?

    I have (I guess had) items in my account Over storage that I haven't been able to access because of this NA server issue. (I'm from Canada, and have a few high level toons on the NA server that I would like to access...)

    Regards.

  2. #2
    Quote Originally Posted by Bennyguy View Post
    Hi,
    OK, so haven't seen any post lately regards to the NA server login issues that many were having just days ago.... Well I can't get on to the NA server at all (I tried for hours...ports open using high speed cable internet). Yet I have NO issue at all logging into the UK server (NONE!!!). Why? And is this happening to others? And are these types of connection posts being deleted?

    I have (I guess had) items in my account Over storage that I haven't been able to access because of this NA server issue. (I'm from Canada, and have a few high level toons on the NA server that I would like to access...)

    Regards.
    Yeah having the same problem, They said they had DDOS attacks that was a few days ago

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts