+ Reply to Thread
Results 1 to 10 of 10
  1. #1

    Defiance 2050 Black Screen

    I launched Defiance 2050 and got stuck at a black screen, the arrow and music loaded but nothing else.

  2. #2
    Quote Originally Posted by Simargi View Post
    I launched Defiance 2050 and got stuck at a black screen, the arrow and music loaded but nothing else.
    Me too??? Help Please?

  3. #3
    A lot of other people are having the same problem.... HELP. PLEASE??????????

  4. #4
    I posted the same issue. But my screen is minimized. But the sound works. Logging in to another Windows User is fixing the issue.

    I cannot find the Defiance 2050 Config yet in AppData.


    Update:
    C:\Users\NEW\AppData\Local\Glyph
    C:\Users\OLD\AppData\Local\Glyph

    Looks like moving these files from the NEW User to the OLD User \AppData\Local\Glyph fixed it for me. But I require more reports on this

  5. #5
    Just an update regarding all the people having black screen issues, Just got an e-mail that says... "Experience Defiance’s sci-fi narrative like never before with 64-bit and DirectX 11 graphics." Defiance runs on Direct X 9... I have windows 7, This is the same thing that happened to me with Elder Scrolls online, But at least I didn`t pay for this game before they went ahead and changed it. Althou... It would have been nice to know the specs before I spent 6 hours downloading the beta! Thanks Glyph!!!!

  6. #6
    Quote Originally Posted by loner614 View Post
    Althou... It would have been nice to know the specs before I spent 6 hours downloading the beta! Thanks Glyph!!!!
    Dude, what? It took me less than 20 minutes.

  7. #7
    same problem here, and i am on windows 10....
    shortest beta ever...

  8. #8

  9. #9
    good guess !
    HKEY_USERS\S-1-5-21-3354806105-2636229075-1870827885-1007\Software\Trion\Channel3\Client
    add DWord key
    DisplayMode
    value 2 : windowed full screen is activated

  10. #10

    Same

    Black screen on Win7x64 with 660gtx and outdated video drivers from november. (I will not further update nvidia software)

    Tried manually adding video settings in registy and running glyph repair per these threads, no luck.

    I noticed in log file that program tries to use appdata for temporary files, instead of obeying custom set environment variables, gotta love bad code. Changed my temp folder to default, no luck.

    I noticed in log file that program is failing to find wad files in directories that don't and have never existed in both games, set defiance and glyph to run as admin, no luck.

    Moved files to my guest pc well under minimum requirements, running updated win10x64, 550ti, and some hex core 2ghz cpu. Works great minus 25fps, I get minimize bug listed in threads still.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts