+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    Member DamianThorn's Avatar
    Join Date
    Mar 2013
    Location
    Rynn without makeup....yummy
    Posts
    95

    Possible sound fix.....

    I have read several folks talk about their sound messing up,and causing a complete restart to temporarily fix the issue.
    I myself have had the sound issue,and went about trying to find a solution...to which I may have found.

    Since doing this,I have played the last 3 nights with no sound issues what-so-ever.

    1-go into sound settings on the PS3 xmb,and DEselect everything that is currently selected. There will be 2 audio settings that you cannot deselect,so those will be the only 2 that will be left.

    2-go into the game menu and disable combat music (it doesn't work anyway)

    Doing these 2 simple steps,it seems to have stopped my sound issues,and I no longer get the "metallic fan sound"

    If you are running through a sound system,I'm not sure if this will work or not...but since I'm only using my T.V speakers,it seems to have corrected the issue.

    Hopefully those of you that have had this issue will find this helpful.

  2. #2
    Junior Member
    Join Date
    May 2013
    Location
    E Yorkshire, Uk
    Posts
    5
    Thanks will give it a try tonight

  3. #3
    Senior Member chrismeyer34's Avatar
    Join Date
    Mar 2013
    Location
    statesboro, ga NA server on the east coast
    Posts
    934
    yeah i had an issue with the " helicopter sound " too, drove me nuts, but its all fixed and all

  4. #4
    it worked before the patch, so im expecting it to be fixed without having to mess with my audio settings which are perfectly fine for ALL other games

  5. #5
    Senior Member
    Join Date
    Mar 2013
    Posts
    858
    If I only played this game I may have changed the sound settings but I play too many games through my SS to be changing all my settings back and forth.

    Good find though, just not for me.

  6. #6
    Member METAL GRINDER's Avatar
    Join Date
    Apr 2013
    Location
    carribbean
    Posts
    36
    I don’t want to touch my XMB settings, but will work with the sound setting in the game. It is worth a try, thanks.

  7. #7
    Junior Member
    Join Date
    May 2013
    Posts
    3
    Turning off Combat Music works. Game needs to be restarted for it to take effect for me but it seems to resolve most of the sound glitch. I still hear a hiccup here and there but my sound hasn't died or got choppy since turning off Combat Music.

  8. #8
    I realized the sounds dies only with optical dolby sourround... total mute and corrupted.

    Using normal TV speaker, sounds thourgh HDMI, no problems.

    I hope they realize its fault of the new patch and will fix it. Trions gave me standard answer to reinstall patch....

  9. #9
    i agree , im not going to switch back and forth between my sound system and tv speakers just because of this game , it works for every game i have , it even did for this one before the latest patch

  10. #10
    Senior Member Assasino's Avatar
    Join Date
    Apr 2013
    Location
    Canada
    Posts
    482
    I never really had issues before the patch (even chat worked awesome) and well we all know what the patches have done.
    I will give it a try, thanks for posting

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts