+ Reply to Thread
Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Mar 2013
    Posts
    25

    NA 360 servers croaked

    Suggest you do an emergency reboot of the NA 360 servers.

    When I have to wait 30 seconds between pushing a button, and something happening, the servers are goofed.

    And no, fanboys, my network connection is just fine. It's only the Defiance game that has a problem. Didn't earlier today.

  2. #2
    Junior Member
    Join Date
    Apr 2013
    Location
    Indiana
    Posts
    3
    I'm having the same issue. The problems started when I logged back in after being kicked off the server right after finishing a co-op.

    1. screens (loadouts, pursuits, contracts, map, etc) taking forever to load
    2. long delay before action happens, after pressing a buttuon

  3. #3
    Junior Member
    Join Date
    Apr 2013
    Posts
    2
    Same here.

  4. #4
    This is really weird. I heard people complaining about this all last night while I was playing, but my game was fine..smooth as silk. But the problems they were describing were clearly server issues (the usual spawn-underground and nothing works kind of thing).

  5. #5
    Senior Member Meela's Avatar
    Join Date
    Apr 2013
    Location
    Ohio
    Posts
    464
    Just started on mine. Did two arkfalls with hellbugs and people that randomly popped in and out. Tried to restart and spawned underground. It finally put me above ground with massive lag.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts